shipping methods not showing on shipping/billing page

SurfShopPRO™ has a powerful new calculation engine. Have you done something special with it? Share your calculation here. Or if you need help with a calc, ask away!

Moderator: frankjan

Post Reply
hshires
Posts: 31
Joined: Jul 23, 2004 8:30 am

shipping methods not showing on shipping/billing page

Post by hshires » Aug 29, 2004 1:50 pm

I have created several shipping methods and defined each in the Calculations Admin.  The "Calc Type" is a field (postal country code) and "Cross Type" is a weight test.  The methods display ("ship via" popup menu) perfectly at final checkout but DO NOT appear at the initial billing/shipping page.  What's interesting is that if I click "Continue Checkout>>" before filling out any billing/shipping fields, the program displays the appropriate "There was a problem with your last submission (see below)." and then updates the "ship via" popup with the correct methods.  Since the methods do display via this inadvertent forcing method, I think the original non-display must be a bug rather than an error with the caluculations.  Any idea how to force refresh the shipping/billing page to correctly display the shipping methods?

Here's the URL.

https://ssl.catalog.com/~tarptent/cgi-b ... p/shop.cgi

Thanks,
Henry Shires

frankjan
Site Admin
Posts: 392
Joined: May 03, 2004 8:57 pm
Contact:

Re: shipping methods not showing on shipping/billing page

Post by frankjan » Sep 02, 2004 8:44 am

hshires wrote:The methods display ("ship via" popup menu) perfectly at final checkout but DO NOT appear at the initial billing/shipping page.
Since you're basing your calculation on a location, your formulas won't work until they get the info they need.  When the customer first gets to the Billing Information page, the freight formulas haven't been given the ship to country yet, so that's why you have to "force" it to get it to display properly.
What's interesting is that if I click "Continue Checkout>>" before filling out any billing/shipping fields, the program displays the appropriate "There was a problem with your last submission (see below)." and then updates the "ship via" popup with the correct methods.
At this point, the formula has what it wants, so it will display correctly now.
Since the methods do display via this inadvertent forcing method, I think the original non-display must be a bug rather than an error with the caluculations.  Any idea how to force refresh the shipping/billing page to correctly display the shipping methods?
It's not a bug.  It's just the way the formula works.  If you didn't base your formula on user input information -- say it was based on just the weight -- the formula would display properly at all times.

I know it's not what you wanted to hear, but hopefully it helps.  My suggestion would be to take the freight pop up off the Billing Info page so as not to confuse customers.  They can then choose the ship via method on the next page.

EDIT: This functionality was added in SurfShopPRO v1.4.6
Frank Jance
SurfShop Forum Admin

Setting Up Shop Has Never Been Easier!

lindacalkins
Posts: 13
Joined: Sep 06, 2004 10:36 am
Location: Rochester, MN
Contact:

Post by lindacalkins » Sep 13, 2004 5:43 am

How do you take it off the first page? I was having the same confusing thing happen.
Linda Calkins

frankjan
Site Admin
Posts: 392
Joined: May 03, 2004 8:57 pm
Contact:

Re: shipping methods not showing on shipping/billing page

Post by frankjan » Sep 13, 2004 8:57 pm

The code for the pop up menu is located on the info.htm page. Remove the <! shipmethod> tag.
Frank Jance
SurfShop Forum Admin

Setting Up Shop Has Never Been Easier!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest